Email subscription notifications not working or delayed

Minor incident Status Pages
2022-06-09 14:25 CEST · 4 hours, 50 minutes

Updates

Resolved

Mailgun seems to have successfully implemented a fix for the issue, and email deliverability has been restored.

June 9, 2022 · 21:58 CEST
Issue

Our email provider is currently experiencing an outage, that’s affecting their outbound email delivery, which prevents us from delivering incident and maintenance email notifications currently.

We’re closely monitoring this incident, and considering alternatives in case this is not solved promptly.

You can follow this incident in Mailgun’s status page: https://status.mailgun.com/.

June 9, 2022 · 16:38 CEST

← Back