EU - Status pages & admin dashboard unavailable
Major incident
Status Pages
Admin Site
Regions
EU
2025-11-05 08:34 CET
· 15 minutes
Updates
Resolved
November 5, 2025 · 08:49 CET
The incident upstream has been resolved, and services are back to operational. We’re continuing to monitor this closely.
Issue
November 5, 2025 · 08:34 CET
Because of an upstream incident with our cloud provider, the admin dashboard and status pages are temporarily unavailable. We’re investigating this and will provide updates soon.
← Back
StatusPal Status